การตั้งค่า HSRP on Router แบบพื้นฐาน

สวัสดีครับ ในบทความนี้ ผมจะมาพูดถึงการตั้งค่า HSRP บน Router กันนะครับ ซึ่งเป็นการตั้งค่าแบบ 1 group (1 VLAN , 1 Subnet) ก่อนนะครับ สำหรับท่านใดที่ยังไม่รู้จัก HSRP ท่านสามารถอ่านได้จากบทความนี้ก่อนนะครับ
>> การสำรองเส้นทางโดยใช้ HSRP (Gateway Redundancy) <<

การตั้งค่า HSRP บน Router

Image 3การตั้งค่าที่ R1

  • ตั้งค่า IP address

R1>enable
R1#configure terminal
R1(config)#interface gigabitEthernet 0/0
R1(config-if)#ip address 192.168.10.2 255.255.255.0
R1(config-if)#no shutdown

  • ตั้งค่า HSRP โดยใช้ Group 10 และมี Virtual IP เป็น 192.168.10.1

R1(config-if)#standby 10 ip 192.168.10.1

  • ตั้งค่า HSRP ให้ R1 ทำหน้าที่ Active โดยกำหนด Priority ให้มีค่าสูกว่า R2 ที่เป็น Standby Router
    (Default Priority = 100)

R1(config-if)#standby 10 priority 110

  • เมื่อ R1 ที่เป็น Active เกิด down ลงไป R2 จะ Active ขึ้นมาแทน แต่เมื่อ R1 กลับขึ้นมาใช้งานได้ จะไม่กลับมา Active ซึ่งจะทำหน้าที่เป็น Standby และ R2 ก็ยังคงเป็นตัว Active เหมือนเดิม แม้ R1 จะมี Priority สูงกว่าก็ตาม
  • ในกรณีนี้เราสามารถตั้งค่าให้ HSRP ตรวจสอบค่า Priority และกลับมาใช้ Active บน Router ที่มีค่า Priority สูงกว่าได้ โดยใช้คำสั่ง “preempt”

R1(config-if)#standby 10 preempt

สรุปการตั้งค่า HSRP ที่ R1

R1#show run interface gi0/0
Building configuration…
!
interface GigabitEthernet0/0
ip address 192.168.10.2 255.255.255.0
standby version 2
standby 10 ip 192.168.10.1
standby 10 priority 110
standby 10 preempt
!


การตั้งค่าที่ R2

  • ตั้งค่า IP address

R2>enable
R2#configure terminal
R2(config)#interface gigabitEthernet 0/0
R2(config-if)#ip address 192.168.10.3 255.255.255.0
R2(config-if)#no shutdown

  • ตั้งค่า HSRP โดยใช้ Group 10 และมี Virtual IP เป็น 192.168.10.1

R2(config-if)#standby 10 ip 192.168.10.1

  • ตั้งค่า HSRP ให้ R2 ทำหน้าที่ Standby โดยกำหนด Priority ให้มีค่าต่ำกว่า R1 ที่เป็น Active Router
    (Default Priority = 100)

R2(config-if)#standby 10 priority 100
!! ถ้าต้องการตั้งค่าให้ Priority = 100 ไม่จำเป็นต้องใส่ก็ได้ เพราะ default มันคือ 100 อยู่แล้ว

  • ตั้งค่า preempt เหมือนกับที่ตั้งค่าบน R1

R2(config-if)#standby 10 preempt

สรุปการตั้งค่า HSRP ที่ R2

R2#show run interface gi0/0
Building configuration…
!
interface GigabitEthernet0/0
ip address 192.168.10.3 255.255.255.0
standby version 2
standby 10 ip 192.168.10.1
standby 10 priority 100
standby 10 preempt
!


การตรวจสอบการตั้งค่า HSRP เบื้องต้น

Image 4

 

 

Image 5

 

 

 

Interface – Interface ที่ใช้งาน HSRP
Grp – เลขกลุ่มของ HSRP (1 group ต่อ 1 subnet)
Pri – ค่า priority ของ HSRP (ค่าสูงเป็น active)
P – ถ้ามีตัวอักษร P แสดงว่าเปิดใช้งาน preempt
State – แสดงสถานะของ HSRP ว่า Active หรือ Standby
Active – บอกว่า Router ตัวไหน Active อยู่ (ถ้าเป็นตัวเองจะแสดง local ถ้าไม่ใช่ตัวเองจะแสดงเป็น IP ของ Router ที่เป็น Active)
Standby – บอกว่า Router ตัวไหน Standby อยู่ (ถ้าเป็นตัวเองจะแสดง local ถ้าไม่ใช่ตัวเองจะแสดงเป็น IP ของ Router ที่ Standby)
Virtual IP – แสดงค่า Virtual IP ซึ่งบน Router ทั้ง 2 ตัวที่อยู่ใน group เดียวกัน (subnet เดียวกัน) จะต้องตรงกัน

โอเคครับ ในบทความนี้ เป็นการตั้งค่า HSRP บน Router แบบ 1 group (1 VLAN , 1 Subnet) นะครับ ซึ่งถ้าเราใช้งานมากกว่า 1 VLAN และเราต้องการแบ่งโหลด ก็สามารถทำได้ครับ ตัวอย่างเช่น
ในระบบเรามี 4 VLANs เราสามารถตั้งค่าให้ VLAN 1 , 2 ไป Active ที่ R1 และ VLAN 3 , 4 ไป Active ที่ R2 ได้ โดย traffic ก็จะวิ่งไปผ่านตัว Router ที่ Active ของแต่ละ VLAN ครับ ก็จะสามารถแบ่งโหลดได้เช่นกัน
รอติดตามในบทความถัดไปนะครับ 🙂

Facebook Comments

comments